Security SSL/TLS 历史及概述

PKI应用:SSL/TLS、HTTPS、SSH概述。

SSL/TLS 历史

1994年,NetScape设计了SSL1.0,但未发布。
1995年,NetScape发布了SSL2.0,很快发现有严重漏洞。
1996年,SSL3.0 问世,得到大规模应用, 2015年发现漏洞POODLE。

1999年,ISOC定义发布SSL的升级版TLS1.0 RFC2246。
2006年,TLS1.1 RFC4346。
2008年,TLS1.2 RFC5246。
2011年,禁止SSL2.0 RFC6176。

2014年,TLS1.3 开始筹备 draft-ietf-tls-rfc5246-bis-00。
2018年,TLS1.3 第28草案 draft-ietf-tls-tls13-28。

SSL/TLS 体系

Secure Socket Layer

SSL, 安全套接字层, 传输层之上,对Socket连接的加密协议。实现客户端和服务器之间的安全传输。

SSL 3.0 漏洞 POODLE

2014年10月15日,Google发现一个关于SSLv3的高危漏洞, 命名为POODLE( Padding Oracle On Downgraded Legacy Encryption )。
POODLE。

Transport Layer Security

TLS,传输层安全, 同样是传输层之上,用于任何两个应用程序之间的安全传输。
TLS是基于SSLv3的后续发展

OpenSSL

OpenSSL是SSL/TLS的一种开源实现。

HTTPS

HTTPS,应用层协议,是在传输层使用SSL/TLS加密的HTTP, 通过443端口实现。

Secure Shell

SSH, 应用层通信加密协议,通常用于远程登录会话。

OpenSSH

OpenSSH是SSH的一种开源实现。

0%